logo
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
dbrn  
#1 Posted : Tuesday, January 6, 2015 8:34:08 PM(UTC)
dbrn

Rank: Member

Groups: Registered
Joined: 10/15/2012(UTC)
Posts: 13

Hi, can you please help?

Since making a normal password change in Groupwise, I've had problems syncing between Groupwise and Google. Syncing works when I run it manually through the SyncJob UI, but nothing works to automate syncing.

I had been automating syncing with the command line version of SyncJob through December 2014, having written a batch file that ran through the Win 7 Task Scheduler. But as of Jan 5 2015, it breaks at 'Logging in using MultiLogin'. I get a long error message every time, even though I have updated it to the new Groupwise password. This is the error message, copied from my sync.log (with personal data removed):

5/1/2015 10:38:00 Version: SyncJobCalendar 1.4.0.42772
5/1/2015 10:38:00 Licensed to: --
5/1/2015 10:38:00 Main: Last sync date/time: 12/15/2014 4:38:12 PM
5/1/2015 10:38:00 Main: Syncing from 12/6/2014 12:00:00 AM to 7/4/2015 12:00:00 AM
5/1/2015 10:38:00 GoogleData: Connecting to account: --
5/1/2015 10:38:00 GoogleData: Retrieving Calendar Data (--)
5/1/2015 10:38:01 GroupWise: Connecting to account: --
5/1/2015 10:38:01 GroupWise: Logging in using MultiLogin.
5/1/2015 10:38:09 EXCEPTION: Login unsuccessful
5/1/2015 10:38:09 Main: Logging exception: System.Runtime.InteropServices.COMException (0x80004005): Login unsuccessful
at System.RuntimeType.ForwardCallToInvokeMember(String memberName, BindingFlags flags, Object target, Int32[] aWrapperTypes, MessageData& msgData)
at GroupwareTypeLibrary.DIGWSession5.MultiLogin(String vUserID, Object vCommandLine, Object vPassword, Object vWhenToPrompt, Object vReserved)
at GroupWiseApi.GroupwiseConnector.ConnectCalendar(String server, Int32 port, String user, String password, Boolean usemultilogin)
at CalendarSyncUtil.Program.Synchronize(SynchronizationSettings ss, ProgressInformation progressLink, Boolean debugMode)
at CalendarSyncUtil.Program.Synchronize(SynchronizationSettings settings, Boolean debugMode)
at CalendarSyncUtil.Program.Main(String[] args)
5/1/2015 10:38:09 Main: Fatal Exception, exiting...



So I have tried using the SyncJob UI to automate by clicking on 'Settings...' and using the SyncJob dialogue to create an even in the Task Scheduler. The event runs but my calendars do not sync. This is what sync.log reports (personal data removed):

6/1/2015 11:49:24 Version: SyncJobRunner 1.4.1.423
6/1/2015 11:49:24 Main: Going to look in path: C:\SyncJob\SyncJobCalendar\
6/1/2015 11:49:24 Main: Executing file C:\SyncJob\SyncJobCalendar\--.sjcl
6/1/2015 11:49:24 Main: Executing: C:\SyncJob\SyncJobCalendar\SyncJobCalendar.exe -gwu="--" -gws=server -gwq=1677 -gwc="Calendar" -gwm=False -gdu="--" -gdc="--" -gwi=False -gda=False -fut=180 -pst=30 -rdp=C:\SyncJob\SyncJobCalendar\
6/1/2015 11:49:24 Version: SyncJobCalendar 1.4.1.423
6/1/2015 11:49:24 Licensed to: --
6/1/2015 11:49:24 Main: Last sync date/time: 1/6/2015 10:22:14 AM
6/1/2015 11:49:24 Main: Syncing from 12/7/2014 12:00:00 AM to 7/5/2015 12:00:00 AM


I've been working on this for 4 hours and am totally stumped. One specific question: In the Task SCheduler dialogue, under 'General' and then 'Security Options', I've got "SYSTEM" listed under "When running the task, use the following user account:". Could that be a problem? I've tried changing it, but always get a Windows error message.

Yeah, please help!!
nschoot  
#2 Posted : Thursday, January 8, 2015 9:25:32 PM(UTC)
nschoot

Rank: Administration

Groups: SyncJob Calendar Moderator, Administrators
Joined: 9/13/2011(UTC)
Posts: 160
Man

Thanks: 5 times
Was thanked: 2 time(s) in 2 post(s)
Originally Posted by: dbrn Go to Quoted Post
Hi, can you please help?

Since making a normal password change in Groupwise, I've had problems syncing between Groupwise and Google. Syncing works when I run it manually through the SyncJob UI, but nothing works to automate syncing.

I had been automating syncing with the command line version of SyncJob through December 2014, having written a batch file that ran through the Win 7 Task Scheduler. But as of Jan 5 2015, it breaks at 'Logging in using MultiLogin'. I get a long error message every time, even though I have updated it to the new Groupwise password. This is the error message, copied from my sync.log (with personal data removed):

I've been working on this for 4 hours and am totally stumped. One specific question: In the Task SCheduler dialogue, under 'General' and then 'Security Options', I've got "SYSTEM" listed under "When running the task, use the following user account:". Could that be a problem? I've tried changing it, but always get a Windows error message.

Yeah, please help!!

This looks like it has to do with the access rights of the scheduled task. The scheduled task most likely has insufficient rights to access the network to login to Groupwise. This can be fixed by changing the security options on the General tab.

Please try changing it to "Run only when user is logged on" and make sure that your user is filled in in the option "When running the task, use the following user account".

If the scheduled task works, it was indeed the security settings that caused the problem.

I hope this helps.
Niels Schoot
Syncjob Developer
dbrn  
#3 Posted : Thursday, January 8, 2015 10:51:53 PM(UTC)
dbrn

Rank: Member

Groups: Registered
Joined: 10/15/2012(UTC)
Posts: 13

Yes, that did the trick. Thank you!
dbrn  
#4 Posted : Thursday, January 8, 2015 11:29:27 PM(UTC)
dbrn

Rank: Member

Groups: Registered
Joined: 10/15/2012(UTC)
Posts: 13

BUT, now, every time the task runs a dialogue window pops up! From reading around online, it seems like this is a non-changeable attribute of using this setting ("Run only when user is logged on") in Task Scheduler. It's not a problem, but it's not ideal either!

Could you add some code to Syncjobrunner so that it always runs minimized? It would still blink up on the screen, but at least this way it would disappear right away, which is actually what my old command line syncjob .bat used to do. Or anything else...?
nschoot  
#5 Posted : Monday, January 12, 2015 11:34:53 AM(UTC)
nschoot

Rank: Administration

Groups: SyncJob Calendar Moderator, Administrators
Joined: 9/13/2011(UTC)
Posts: 160
Man

Thanks: 5 times
Was thanked: 2 time(s) in 2 post(s)
Originally Posted by: dbrn Go to Quoted Post
BUT, now, every time the task runs a dialogue window pops up! From reading around online, it seems like this is a non-changeable attribute of using this setting ("Run only when user is logged on") in Task Scheduler. It's not a problem, but it's not ideal either!

Could you add some code to Syncjobrunner so that it always runs minimized? It would still blink up on the screen, but at least this way it would disappear right away, which is actually what my old command line syncjob .bat used to do. Or anything else...?

Is this the Groupwise "connecting to server" dialog or a SyncJob dialog? You could try checking the "hidden" checkbox of the scheduled task, but I'm not sure if this dialog can be supressed.


Niels Schoot
Syncjob Developer
dbrn  
#6 Posted : Monday, January 12, 2015 7:51:53 PM(UTC)
dbrn

Rank: Member

Groups: Registered
Joined: 10/15/2012(UTC)
Posts: 13

This is the Syncjob dialogue, and the 'hidden' box is checked.

I think you're right that Windows won't suppress this kind of dialogue. SO, would you consider adding a 'run minimized' argument to syncjobrunner.exe?
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.